Jump to content
swimfrost

Horrible FPS

Recommended Posts

I know my computer is well equipped to play the game efficiently, because it has worked just fine, but at times I have horrible fps. It has dropped as low as 0.4. It did not do this until after the first major update, 1.1. Has anyone else had this kind of issue?

Share this post


Link to post
Share on other sites

Hey, I had horrible FPS as well when I first started playing. I recommend turning off the shadows like Guardian said, it DRASTICALLY improved my game-play. Also if you can handle playing with low textures turn them down too. I did those things and now SWTOR runs a lot smoother and is actually playable. :)

Share this post


Link to post
Share on other sites

If you're still having problems after turning off the shadows, try turning off Vertical Syncing as well. Once I did that I got another little boost in FPS. ;)

Share this post


Link to post
Share on other sites

Yup shadows and Vsync are often the culprit. You could also try to update video drivers for your card. It fixed some issues for me during the beta. Another possibility is that you have low RAM on the card or in the system, and the game is transferring game textures to the page file too often which would cause huge lag. Or perhaps it's a problem in the game itself, after all it's very new still.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...